What Do You Do When Your Board Is No Longer Detected by Vivado?

How to Fix Board Connection Errors in Vivado and EEPROM

It can be very frustrating to purchase a new board and run into a road block when testing out your configuration and your Vivado Hardware Manager isn’t recognizing it. You load and unload Vivado until you’re blue in the face, and everything seems in place, but you’re still not able to see the board.

    • Check USB cables, ports, whether or not cable was plugged upside down and in the correct header on board
    • Check to see if your board is detected by the OS
      • In the Windows Device Manger, upon connecting the Basys 3 you should be able to a USB Serial Converter A and a USB Serial Converter B appear under the Universal Serial Bus controllers dropdown. If you look in the ‘Properties’ pane in the ‘Details tab’ and look at the “Bus reported device description” dropdown in the Property dropdown, it should say “Digilent USB Device”.Looking for USB Device in Device Manager
      • Linux based? Try going through the steps to view a USB
      • Your board should appear as a Digilent USB device
    • Alternatively, can download the Adept software and see if you board is visible. (windows use the GUI, Linux use Adept.exe DmgrEnum)
    • Check to confirm that cable drivers are installed: https://www.xilinx.com/support/answers/59128.html
    • If EEPROM not found determined to have been overwritten by FT_PROG, post on a Forum thread to get messaged an application.

If you’reĀ still not having your board recognized, it might be time to admit that it’s a dead board (We know! We don’t want it either!). In this case, visit digilent.com and follow the process for a return.

Be the 1st to vote.

Leave a Reply

Your email address will not be published. Required fields are marked *